Haohaooo's ACM Life

I am moving closer to my dream!

2014 Multi-University Training Contest 9#6

Fast Matrix CalculationTime Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 424    Accepted Submission(s): 219


Problem Description

One day, Alice and Bob felt bored again, Bob knows Alice is a girl who loves math and is just learning something about matrix, so he decided to make a crazy problem for her.

Bob has a six-faced dice which has numbers 0, 1, 2, 3, 4 and 5 on each face. At first, he will choose a number N (4 <= N <= 1000), and for N times, he keeps throwing his dice for K times (2 <=K <= 6) and writes down its number on the top face to make an N*K matrix A, in which each element is not less than 0 and not greater than 5. Then he does similar thing again with a bit difference: he keeps throwing his dice for N times and each time repeat it for K times to write down a K*N matrix B, in which each element is not less than 0 and not greater than 5. With the two matrix A and B formed, Alice’s task is to perform the following 4-step calculation.

Step 1: Calculate a new N*N matrix C = A*B.
Step 2: Calculate M = C^(N*N). 
Step 3: For each element x in M, calculate x % 6. All the remainders form a new matrix M’.
Step 4: Calculate the sum of all the elements in M’. 

Bob just made this problem for kidding but he sees Alice taking it serious, so he also wonders what the answer is. And then Bob turn to you for help because he is not good at math.

 


Input

The input contains several test cases. Each test case starts with two integer N and K, indicating the numbers N and K described above. Then N lines follow, and each line has K integers between 0 and 5, representing matrix A. Then K lines follow, and each line has N integers between 0 and 5, representing matrix B.

The end of input is indicated by N = K = 0.

 


Output

For each case, output the sum of all the elements in M’ in a line.

 


Sample Input

4 25 54 45 40 04 2 5 51 3 1 56 31 2 30 3 02 3 44 3 22 5 50 5 03 4 5 1 1 05 3 2 3 3 23 1 5 4 5 20 0

 


Sample Output

1456



问题:一开始的矩阵快速幂模板好像有点问题,改了之后还不对,原来是初始化的问题,又是没有初始化为0,导致加的时候出错。关键是它第一组是对的,后面就不对了,真实奇怪!


这一题思路还是很简单的,只是比赛的时候没去认真想。。。就去做其他题了。。。

(A*B)^1000*1000矩阵相乘,可以转化为A*(B*A)^(100*100-1)*B 运算次数减少很多,然后不要忘记是(1000*1000-1)


#include <cstring>

#include <iostream>

#include <algorithm>

#include <cstdio>

#include <cmath>

#include <map>

#include <cstdlib>

#define M(a,b) memset(a,b,sizeof(a))

using namespace std;


const int SMod = 6;

int N,K;


struct Matrix

{

    int m[1001][6];

};


Matrix Mul(Matrix a,Matrix b,int mm,int kk,int nn)

{

    Matrix c;

    memset(c.m,0,sizeof(c.m));

    for(int i=0;i<mm;i++)

        for(int j=0;j<nn;j++)

            for(int k=0;k<kk;k++)

                c.m[i][j] += (a.m[i][k]*b.m[k][j])% SMod, c.m[i][j]%=6;

    return c;

}


Matrix MPow(Matrix a,int n,int nn)

{

    Matrix res;

    memset(res.m,0,sizeof(res.m));

    for(int i = 0;i<nn;i++)

        res.m[i][i] = 1;

    while(n)

    {

        //cout<<n<<'!'<<endl;

        if(n&1)

            res = Mul(res,a,nn,nn,nn);

        n>>=1;

        a = Mul(a,a,nn,nn,nn);


    }


    return res;

}


int A[1001][6],B[6][1001],C[1001][1001],D[1001][1001];


int main()

{

   while(scanf("%d%d",&N,&K)==2&&N+K!=0)

   {

       Matrix M,te;

       M(M.m,0);

       M(te.m,0);

       M(A,0);

       M(B,0);

       M(C,0);

       M(D,0);

       for(int i = 0;i<N;i++)

        for(int j = 0;j<K;j++)

       {

           scanf("%d",&A[i][j]);

       }

       for(int i = 0;i<K;i++)

        for(int j = 0;j<N;j++)

       {

           scanf("%d",&B[i][j]);

       }

        for(int i=0;i<K;i++)

        for(int j=0;j<K;j++)

            for(int k=0;k<N;k++)

                M.m[i][j] += (B[i][k]*A[k][j])%SMod, M.m[i][j]%=SMod;


       int ans = 0;

       te = MPow(M,N*N-1,K);

        for(int i=0;i<N;i++)

        for(int j=0;j<K;j++)

            for(int k=0;k<K;k++)

                C[i][j] += ((A[i][k]*te.m[k][j])%SMod + SMod) % SMod;


        for(int i=0;i<N;i++)

        for(int j=0;j<N;j++)

            for(int k=0;k<K;k++)

                D[i][j] += ((C[i][k]*B[k][j])%SMod + SMod) % SMod;


       for(int i = 0;i<N;i++)

         {for(int j = 0;j<N;j++)

         {

             //cout<<D[i][j]%SMod<<' ';

             ans+=D[i][j]%SMod;

         }

           //cout<<endl;

         }

       printf("%d\n",ans);

   }

   return 0;

}


评论

© Haohaooo's ACM Life | Powered by LOFTER